1997 Gmc Sierra Cranks But No Start

Discussion in 'General Motors Products' started by jdmintegra707, Dec 18, 2009.

  1. jdmintegra707

    jdmintegra707 New Member

    hi everyone my name is diego i got a 1997 gmc sierra vortec 4.3 and it cranks but no start i have had this issue before and it only does it when its cold so i did alittle of diagnosing my self and found the ignition control module was bad so i replaced it and started up and been driving it for awhile and now we got cold weather and its doin the crank no start again so i was wondering if anyones got any advice for me and help me with my beast lol thanx
  2. Crew Chief

    Crew Chief Crew Cheif/Site Admin Administrator

    It is likely the fuel pump spray carb clean into the throttle body and see if it starts if so check the filter and if that is OK repkace the pump. 99 times out of a hundred on a vortec it is the fuel pump if they wont start cold. They are fussy on fuel pressure and volumn.
  3. jdmintegra707

    jdmintegra707 New Member

    ok so i got the carb cleaner and sprayed in the throttle body and still no start so im assuming its a spark issue so im going to check the spark and go from there last time this happened and wouldnt start cold i ended up replacing the inition control module and fix this issue. but im not so sure if thats gonna be the problem again thanx guys any info would be much appreciated.
  4. Crew Chief

    Crew Chief Crew Cheif/Site Admin Administrator

    Did you install an aftermarket module if you in fact have no spark I would check this first I have had bad luck with aftermarket modules about the only other problem that I have seen with this vortec is the cam or crank sensors, and this is rare, it is unusual to see a module go bad. I would give the module wiring and connections a careful inspection if this is your problem.
  5. jdmintegra707

    jdmintegra707 New Member

    the first time my truck had this problem i purchased a ac delco icm and so to day i went out and bought an aftermarket icm and there is still no spark so maybe a coil? but i have noticed that when i try starting my truck just cranks but no start and so when i release the key back to accessory the motor like jumps like i wanna say if i were cranking the motor over just once , a friend from work said there is a part on the distributor called the pick up coil he said that could be a possibility?
  6. jdmintegra707

    jdmintegra707 New Member

    ok so my truck has weak spark after replacing the icm any ideas would be usefull thanks
  7. Crew Chief

    Crew Chief Crew Cheif/Site Admin Administrator

    The first cultrip for weak spark is always the coil how weak and what are you using for a comparision you have to be sure you are not seeing the waste spark or the secondary as it is sometimes called this always looks a little on the weak side.
  8. jdmintegra707

    jdmintegra707 New Member

    ok i got a spark tester with a bulb in it and the bulb barely lights up when my truck is being cranked so i threw the spark tester on my moms tahoe and it lights up bright jusr making sure the spark tester was ok thats what i was thinking to it is the coil is there any way to test the coil to see if its bad
  9. Crew Chief

    Crew Chief Crew Cheif/Site Admin Administrator

    If you catch the right counter guy that is interested in helping not just selling parts a few after market can test coils if you have to pay for diagnostics it is chesper just to repalce the coil. are you sure you had a good ground on your vehicle I have seen this look like low spark. Also if it an older Tahoe it may look like a stronger spark but this is rare
  10. 96gmc4.3

    96gmc4.3 New Member




    What was the fix for this?

    Any help appreciated.

    Thanks.

    96gmc4.3
  11. Crew Chief

    Crew Chief Crew Cheif/Site Admin Administrator

    If I remember correctly he had a bad fuel pump but I dont recall for sure. A 4.3 no start is usually caused by the fuel pump the parameters for this fuel delivery system has to be right on to start cold. I will need more info tp help you.
    When doesnt it start
    Have you tried anything
    Does it have spark and if so have you sprayed carb cleaner into the throttle body
    mileage
    can you here the fuel pump run

Share This Page